Bug #34

fixing the reuse of open documents

Added by J. Templ over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:03/26/2015
Priority:NormalDue date:
Assignee:J. Templ% Done:

100%

Category:-
Target version:1.7
Forum topic:

Description

When clicking on a link to a help text that is already open within BlackBox,
a new help text window is opened. This is in contrast to the expected behavior of
reusing the open window (bring to front) as it is done when editing documents.
The reason is a very unsystematic treatment of reuse of open documents in BB 1.6
based mainly on the window title.
Related anomalies arise with other document modes (except edit mode)
and need to be taken into account when changing this behavior.
There are also cases with tool dialogs where there is a wrong reuse if
the same window title is used for different documents.
A proposal for a systematic treatment of reuse of open documents based on
file name, location and document flags instead of window titles is available in CPC 1.7 rc5.

Refers to CPC 1.7 rc5 change list item 9 and Open Points 05.

Associated revisions

Revision 775622e5
Added by J. Templ over 4 years ago

reuse of open documents generalized. Refs: #34.
Changes as proposed in CPC 1.7 rc5.
The core of the changes is the new procedure Windows.GetBySpec,
which centralizes the reuse behavior based on file name, location,
converter and document flags. Reuse happens only for documents
with the same flags, e.g. an aux window is only reused for
another aux window. Thereby it is possible to edit and browse
a document independently as it was before.

Signed-off-by: Josef Templ <>

Revision a8269d33
Added by J. Templ over 4 years ago

Title check added for window reuse in Windows.GetBySpec. Refs: #34.
An empty title means that there is no title check.

Signed-off-by: Josef Templ <>

Revision 651e75e3
Added by J. Templ over 4 years ago

Merge pull request #18 from BlackBoxCenter/issue-#34

Refs: #34.

Revision ca1a670a
Added by J. Templ over 4 years ago

Revert "Title check added for window reuse in Windows.GetBySpec." Refs: #34.

This reverts commit a8269d3338fc6e0c6e94015b880d004f858049ba.

The title check did not work properly together with the Info->Source command
because the window is searched first without a title and later it is searched again with
a title that is not the real window title but the file name.
So the window is found for reuse in the first search but not in the second search resulting
in an inconsistency in the window management.

Signed-off-by: Josef Templ <>

Revision f0255de3
Added by J. Templ over 4 years ago

Merge pull request #23 from BlackBoxCenter/issue-#34

Revert "Title check added for window reuse in Windows.GetBySpec." Refs: #34.

History

#1 Updated by J. Templ over 4 years ago

  • Description updated (diff)

#2 Updated by J. Templ over 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF