Bug #24

Fixing the name table handling in DevLinker

Added by J. Templ over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:01/15/2015
Priority:NormalDue date:
Assignee:J. Templ% Done:

100%

Category:-
Target version:1.7
Forum topic:

Description

DevLinker.LinkDll causes a name table overflow (TRAP in DevLinker.Insert)
when the average of the involved name lengths is more than about 20.
This is caused by a fixed size of the name table that is appropriate
only when the names are shorter on average.
Reported by Rainer Neubauer, 2008-02-18

In addition, testing for the need to append the ".dll" suffix in DevLinker.Insert causes a TRAP
when the name table is filled with less than 4 characters.
Reported by Boris Ilov, 2013-08-26.

In addition, the CP compiler accepts longer names than DevLinker does.
This is caused by declaring Name as an ARRAY 40 OF SHORTCHAR in DevLinker instead of 256.
Reported by Josef Templ, 2015-01-15.

Refers to CPC 1.7 change list number 6.

Associated revisions

Revision 4e32252d
Added by J. Templ over 4 years ago

Changes as proposed by Rainer Neubauer. Refs: #24.

Revision 5d02e8da
Added by J. Templ over 4 years ago

Changes as proposed by Boris Ilov. Refs: #24.

Revision c4ccbf16
Added by J. Templ over 4 years ago

Changes as proposed by Josef Templ. Refs: #24.
Fixes a logical error in Boris' proposal.
Introduces names as large as CP identifiers and introduces name table overflow handling similar to the fixups table instead of allocating a very large name table.

Signed-off-by: Josef Templ <>

Revision b3f4fc50
Added by J. Templ over 4 years ago

Merge pull request #10 from BlackBoxCenter/issue-#24

Refs: #24.

History

#1 Updated by J. Templ over 4 years ago

  • Status changed from New to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF