Bug #17

Fixing a bug in command line reading

Added by J. Templ almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:09/30/2014
Priority:NormalDue date:
Assignee:J. Templ% Done:

0%

Category:-
Target version:1.7
Forum topic:

Description

Command line reading cuts off the last character resulting in
nondeterministic results for Dialog.commandLinePars.
The bug is caused by an off-by-one error in HostMenus.IncludingFileCommandLine.

Reported by Eugene Temirgaleev 2009-10-11.
OberonCore B8
CPC 1.7 change list number 27.

Associated revisions

Revision e78cc642
Added by J. Templ almost 5 years ago

Bug fix as suggested by Eugene Temirgaleev. Refs: #17.

Signed-off-by: Josef Templ <>

Revision a7e5305a
Added by J. Templ almost 5 years ago

Removing the bug fix from subsystem Script. Refs: #17.
Since the bug has been fixed in HostMenus, there is no need any longer to fix it in subsystem Script.

Signed-off-by: Josef Templ <>

Revision 50e5188d
Added by J. Templ almost 5 years ago

Merge pull request #4 from BlackBoxCenter/issue-#17

Refs: #17.

History

#1 Updated by J. Templ almost 5 years ago

  • Description updated (diff)

#2 Updated by J. Templ almost 5 years ago

  • Status changed from New to Closed

Also available in: Atom PDF