Infrastructure #112

producing a change list from Redmine

Added by J. Templ over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:05/09/2016
Priority:NormalDue date:
Assignee:J. Templ% Done:

100%

Category:-
Target version:1.7
Forum topic:

Description

For the upcoming 1.7 release and for further developments a file that contains a change list is needed. The change list can be included in the distribution and/or put on the web. The changes can be downloaded from the Redmine issues as an xml file and converted into an odc file and/or html.

Associated revisions

Revision d2fd9111
Added by J. Templ over 3 years ago

adding a change list automatically when building master. Refs: #112.
ScriptChanges converts the file blackbox_issues.xml into a file BlackBox_<appVersion>_Changes.odc by using the external subsystem Xmlcore. In order to avoid any build problems in case of future incompatible changes we link ScriptChanges statically to Xmlcore and the base BlackBox modules. The resulting file is bbchanges.exe. It is kept unchanged on the build machine and needs to be re-built manually in case of any changes.
The Redmine issues are downloaded via Python in build.py.

In addition some improvements have been applied:
1. 'git checkout', which always reported an error message, is avoided by using option --branch for 'git clone'.
2. Incrementing the buildNumber multiply in case of an error is now avoided.
3. renameLog checks if outputNamePrefix has been set.
4. Since 'git clone' fails sometimes for unknown reasons, it is treated separately in order to find out what the problem is.

Signed-off-by: Josef Templ <>

Revision 3e18d70a
Added by J. Templ over 3 years ago

fixed_version_id obtained automatically from Redmine. Refs: #112.
No longer hard-coded in build.py and thereby ready for other versions as 1.7.

Signed-off-by: Josef Templ <>

Revision b3c5d976
Added by J. Templ over 3 years ago

conversion of change list to html added. Refs: #112.
plus relative paths changed to absolute paths in build.py for addChanges.

Signed-off-by: Josef Templ <>

Revision 232d5fd4
Added by J. Templ over 3 years ago

git clone called with option -q. Refs: #112.
suppresses the progress reporting on stderr, which would be
misinterpreted as an error by the build script.

Revision 65a78ecf
Added by J. Templ over 3 years ago

.html changes file exported with window title as page title. Refs: #112.

Signed-off-by: Josef Templ <>

Revision c56b765c
Added by J. Templ over 3 years ago

changelist size limit increased from 100 to 200 issues. Refs: #112.

Signed-off-by: Josef Templ <>

Revision b84b5746
Added by Douglas G Danforth over 3 years ago

Merge pull request #127 from BlackBoxCenter/issue-#112

changelist size limit increased from 100 to 200 issues. Refs: #112.

History

#1 Updated by I. Denisov over 3 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF